Versions:

Install Promscale on Debian or Ubuntu

You can install Promscale on any Debian or Ubuntu system where you have an already installed and working Prometheus or OpenTelemetry environment.

Install TimescaleDB and the Promscale extension

To use Promscale you need a TimescaleDB database, as well as the Promscale extension. The Promscale extension contains support functions to improve the performance of Promscale.

Installing TimescaleDB and Promscale extension

  1. Install TimescaleDB following the instructions in the TimescaleDB install page
  2. Install the Promscale extension:
    apt install promscale-extension-postgresql-14

    You can also use other versions of Postgres by changing the version in promscale-extension-postgresql-<version>, Promscale supports Postgres 12, 13 and 14 versions.

Install the Promscale connector

The Promscale Connector consumes PromQL queries natively and fetches data from TimescaleDB to execute them, while SQL queries go directly to TimescaleDB. After you install TimescaleDB and the Promscale extension, you can install the Promscale Connector using this command:

  1. If you are installing Promscale Connector on a different host, You have to setup the timescale package registry similar to TimecaleDB pre-install instructions.
  2. Install Promscale Connector:
    apt install promscale

Found an issue on this page?

Report an issue!

Keywords

Related Content